Pataki: This is the ‘most dangerous time’ since 9/11

07:14 - Source: CNN
Gov. Pataki: U.S. at risk of terror attack
CNN  — 

Former New York governor and Republican presidential candidate George Pataki said in an interview on CNN’s “New Day” that Sen. Rand Paul, is “significantly responsible for the fact” the National Security Agency couldn’t do its job.

Amid an ongoing Senate debate on the Patriot Act, the government’s ability to obtain specific, targeted data on suspects temporarily expired. The NSA officially shut down the bulk metadata collection program officially at 7:44 p.m. Sunday night, a senior government official told CNN.

“This is probably the most dangerous time for Americans here since September 11th, and to now have this void where the NSA cannot track lone wolves, they cannot use roving wiretaps against people they understand, probably are looking to engage in terrorist acts is completely wrong,” Pataki said. “It’s dangerous and I fear for our safety.”

RELATED: Rand Paul vs. the GOP field on NSA

Maine independent Sen. Angus King, who voted against the Freedom Act, said that the Kentucky senator and Republican presidential candidate is “overdoing it.”

“We’ve got half the U.S. Senate, it seems, running for president and we’ve got some important deadlines coming up… and if somebody who is running for president can essentially take over the floor of the U.S. Senate and make this kind of publicity deal it’s going to really impede our ability to get the people’s work done.”

READ: Mike Huckabee to Rand Paul: Decide what job you want

King added that while he thinks Paul’s opinion on NSA surveillance is “genuine,” he is “overstating it significantly.”

“I just worry about the implications of every two or three months, we’ll have somebody running for president taking over in this way and it’s not productive,” said King.

Meanwhile, the Senate is expected to restore the expiring provisions midweek.

RELATED: Patriot Act provisions have expired: What happens now?